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Adobe Flash CS3 Activity 5.1 worksheet 

The Flash workspace 
Student name: ________________________________________________ Date: _______________________ 

Identify the Stage, workspace, Timeline, layers, panels, Tools panel, and Property inspector. 
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Identify the selection tools, the drawing tools, the view tools, and the color tools: 
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The Flash workspace 

Stage
The Stage is the white, rectangular area of the Adobe Flash CS3 workspace (Figure 1). Objects you place on the 
Stage will appear in your published movie. Objects placed in the pasteboard (the gray area around the Stage) will 
not appear in the finished movie, but you can place objects there until you want them to appear on the Stage. 

Timeline StageTools panel PanelsProperty inspector 

Figure 1 Flash workspace 
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Timeline and layers 
The Timeline is where you control the images and sounds in your Flash document (Figure 2). The Timeline is 
divided into frames. You can add content to the frames on the Timeline. 

Current frame, frame rate, and elapsed time are all shown at the bottom of the Timeline. The playhead, represented 
by a red rectangle with a long red line, shows the current frame you are viewing on the Timeline. You can click a 
frame to move the playhead to that frame, or you can drag the playhead back and forth on the Timeline to quickly 
view all or any part of your animation. 

Layers in the Timeline provide a way to organize the elements of your movie. You can draw and edit objects on one 
layer without affecting objects on another layer. Layers control the stacking order of objects—the order moves from 
top to bottom, so objects displayed in front are in the top layer, while objects displayed in back are in the bottom 
layer. This allows you to place objects in front of or behind one another. To change the order of layers, drag the 
layer name to a new position. The layer controls appear on the left side of the Timeline. Each layer has an option for 
hiding or showing the layer, locking it, and displaying its contents as outlines. 

Playhead
Show/Hide  
Layer 

Lock/Unlock
Layer Layers 

Delete Layer FrameCurrent  
frame Rate

Insert
Layer 

Insert Layer 
Folder

Elapsed
Time 

Figure 2 Timeline 

Edit bar 
The edit bar, at the top of the Timeline, lets you quickly navigate between different parts of your Flash document 
(Figure 3). It indicates the current object being edited and lets you switch between scenes and symbols. You can 
also change the magnification level of the Stage. You can also show or hide the Timeline. 

Move Up
A Level 

Change
MagnificationEdit Scene 

Show/Hide 
Timeline

Current  
Object 

Edit Symbols Select Workspace 
Layout 

Figure 3 Edit bar 
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Panels

Panels provide easy access to controls that help you work 
with the content in your document (Figure 4). By default, 
the panels are docked to the right side of the workspace. You 
can undock panel groups, add panels to a group, undock 
individual panels, rearrange the order of docked panels, and 
collapse and close panel groups. To undock a panel, drag it 
by its tab or title bar away from its current position. You can 
drag it into another dock or make it free-floating. 

Figure 4 Panels 

Title bar 

Tab
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Tools panel 
The tools in the Tools panel let you draw, paint, select, and modify artwork, as well as change the view of the Stage 
(Figure 5). The Options area at the bottom of the Tools panel lets you modify a tool you have selected. If the Tools 
panel is not visible, you can display it by selecting Window > Tools. To select a tool, just click it. (You can also use 
the shortcut key shown in parentheses in the tool tip that appears when you rest the pointer over a tool for a few 
seconds.) 

Selection

Free Transform 

Figure 5 Flash Tools panel 

Selection tools 

Selection tool (black arrow): Click an object to select it. Drag a selected object to move it. 

Subselection tool (white arrow): Select and move points of an object or edit paths between adjacent points. 

Free Transform tool: Resize or rotate selected objects by clicking and dragging. Also has the Gradient Transform 
tool (transform a gradient or bitmap fill by adjusting the size, direction, or center of the fill). 

Lasso tool: Click and drag to select an area. 

Drawing tools 

Pen tool: Create straight or curved lines. You can also create Bezier curves. 

Text tool: Create or edit text and text fields. 

Line tool: Draw straight lines. 

Line

Pen

Pencil

Ink Bottle 

Eyedropper 

Hand

Subselection

Lasso

Text

Rectangle

Brush

Paint Bucket 

Eraser

Zoom

Stroke color 

Fill color 

Options Area 
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Rectangle tool: Create rectangles or squares composed of fills and strokes, just fills, or just strokes. Also has the 
PolyStar tool (create either polygon or star shapes—you can set how many points both shapes have), the Oval tool 
(create circles and ovals), the Rectangle Primitive tool, and the Oval Primitive tool. Primitive shapes are individual 
objects that can be edited in the Property inspector. 

Pencil tool: Create lines in any of three modes—straighten, smooth, or ink. 

Brush tool: Create shapes with fills only. 

Ink Bottle tool: Change the color or width of a line, or add a stroke to a shape. 

Paint Bucket tool: Add fill inside a shape or change the fill color. 

Eyedropper tool: Sample a color from swatches or anywhere on the screen. 

Eraser tool: Erase parts of an image. 

View tools 

Hand tool: Drag the Stage to view another part of your document. 

Zoom tool: Zoom in or out to view more or less of the Stage. To zoom out, hold down the Alt key (Windows) or the 
Option key (Mac OS). 

Color tools 

Stroke Color: Set the stroke color. 

Fill Color: Set the fill color. 

Property inspector 
The Property inspector displays options that change according to the current object or tool selection. When you 
open a document, the Property inspector displays document properties. When you select certain tools, it displays 
tool options. When you select a vector object, it displays options such as stroke and fill. You can change these and 
other options directly from the Property inspector. By default, the Property inspector is visible; you can hide or show 
it by selecting Window > Properties > Properties. Figure 6 shows the properties for a text object and a rectangle 
shape, respectively. 

Figure 6 Property inspectors 
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How to create an animated face 
This activity walks you step by step through the process of creating a simple animation by using Adobe Flash CS3. 
You use drawing tools and implement motion and shape tweens. After you test your movie, you publish it for 
playback by others, either through a browser or directly with Flash Player. 

Draw facial features 

Draw the right eye 

1. Start Flash and open a blank new document. 

2. The new document contains one layer and one empty 
keyframe. 

3. Select the Oval tool and draw a small circle to represent 
the right eye on a face (Figure 1).

4. Select the Selection tool and double-click the circle’s 
center to select it. You should see both its outline 
(stroke) and center (fill) selected. 

5. To change the outline color of the eye, click the Stroke 
Color box in the Property inspector and select a new 
color (Figure 2). To change the fill color, use the Fill 
Color box. 

6. On the Timeline, double-click the layer name, Layer 1 
(Figure 3).

This selects the layer name so you can rename it. 

7. Rename the layer Right Eye and press Enter (Windows) 
or Return (Mac OS) (Figure 4). 

Figure 1 Right eye drawn with Oval tool 

Figure 2 Image Property inspector 

Figure 3 Layer name 

Figure 4 New layer name 

Oval tool 

Stroke color Fill color 
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Save the eye graphic as a symbol in the library 

Instead of creating two eyes separately, convert the right eye from a shape to a graphic symbol. This adds the eye to 
the library so you can use it over and over. This will also reduce the size of your finished movie. 

8. On the Right Eye layer, click frame 1 to select it 
(Figure 5).

This automatically selects the contents of frame 1. 

 Note: If the right eye is not completely selected, double-
click the eye on the Stage with the Selection tool to 
select it. 

9. Select Modify > Convert To Symbol. 

The Convert To Symbol dialog box opens (Figure 6). 

10. In the dialog box, name the symbol eye, select Graphic 
as the behavior, and click OK. 

The eye on the Stage is now just an instance (copy) of 
the master eye symbol, which is stored in the library. 
The eye now has a single blue selection border 
(Figure 7) and can be selected with a single click. 

11. Select Window > Library to see that your symbol has 
been added to the Library panel (Figure 8).

Note: You must select the eye symbol in the library to 
see the graphic in the preview window. 

 You can now reuse the eye symbol as many times as 
you want without redrawing it. 

Figure 5 Frame 1 selected 

Figure 6 Convert To Symbol dialog box 

Figure 7 Graphic symbol selected 

Figure 8 Library panel 
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Reuse the eye symbol to create the left eye 

12. Click the Insert Layer button in the lower left corner of 
the Timeline to insert a new layer (Figure 9).

13. Double-click the layer name and change the name to 
Left Eye.

14. On the Left Eye layer, select frame 1. 

15. Select the eye symbol in the Library panel and drag the 
symbol onto the Stage. 

 You now have a second instance of the eye on the Stage. 
Using instances from the library keeps the file size of 
your movie smaller than copying and pasting. Smaller 
movies load faster in a browser. 

Figure 9 Insert Layer button 

Insert Layer button 

Draw the nose 

16. Insert a new layer and name it Nose.

17. Select frame 1 on the Nose layer. 

18. Select the Line tool and draw two lines that form an 
angle to represent a nose (Figure 10).

19. To adjust the angle after you’ve drawn it, use the 
Subselection tool (white arrow) to drag the corner or one 
end of the line. (You might try dragging one end of a 
line with the Arrow tool to see the difference between 
the two tools.) Figure 10 Draw nose 

Add frames to make a three-second movie 

A Flash movie typically plays 12 frames per second. To keep the nose on the Stage for 3 seconds, for example, you 
need to insert 36 additional frames on the Nose layer after frame 1, the current frame. (Starting at frame 1, it will 
take the movie 3 seconds to reach frame 37, because 1 + 36 = 37.) 

20. Select frame 37 on the Nose layer and select Insert > 
Timeline > Frame.  

Flash inserts frames through frame 37 (Figure 11).  

 Observe that the playhead (the red rectangle at the top of
the Timeline) is on frame 37 and that the nose is visible 
but the eyes have disappeared. At the bottom of the 
Timeline, you can see that this movie is currently 37 
frames, is set to play at 12 frames per second, and will 
play for 3 seconds. 

 Note: The keyboard shortcut for inserting a frame is F5. 

21. Drag the playhead to various frames. 

The nose remains visible in frames 1 through 37, but the 
eyes appear only in frame 1. 

22. To see your movie, drag the playhead to frame 1 and 
then select Control > Play. 

 At this point, not much is happening beyond frame 1. 

Figure 11 Frame inserted in Timeline 
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Draw the mouth 

23. Insert a new layer and name it Mouth. 

24. Select frame 1 of the Mouth layer. 

25. Draw a mouth in frame 1. 

� Use the Line tool to draw a straight line 
(Figure 12).

� Select the Selection tool and click on the Stage 
away from the line to deselect it.  

� Move the pointer toward the middle of the line. 
When a curve appears next to the pointer, drag the 
middle of the line downward to create a smile 
(Figure 13).

� When you release the mouse button, only the smile 
remains (Figure 14). 

Figure 12 Mouth as straight line 

Figure 13 Drag line with Arrow tool 

Figure 14 Mouth complete 
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Animate the facial features 

Use motion tweens to animate the eyes 

Because you created the eyes by using a graphic symbol, you can animate them by using a motion tween. To create 
the motion tween, you need a start keyframe and an end keyframe containing the same symbol. You can then use a 
motion tween to fill the frames between the keyframes. 

1. On the Right Eye layer, select frame 37 and select 
Insert > Timeline > Keyframe. This will be the end 
keyframe. 

A keyframe signals Flash that some animation action 
begins or ends at that frame. 

2. On the Right Eye layer, select frame 37 and drag the 
right eye a short distance. 

3. Select any frame between frames 1 and 36 on the Right 
Eye layer. 

4. In the Property inspector, select Motion in the Tween 
menu to create a motion tween (Figure 15). 

 Note: You can also select Insert > Timeline > 
Create Motion Tween. 

Notice the frames containing the motion tween are now 
light blue and contain a solid arrow running from the 
start frame to the end frame (Figure 16).

5. Position the playhead on frame 1 and select 
Control > Play to play your movie and see the effect of 
the motion tween. 

The right eye gradually moves from its original position 
in frame 1 to the new position in frame 37. Notice that 
only the right eye moves. 

 Note: If you want to change the motion, move only the 
symbol in keyframe 37. 

6. Select frame 37 on the Left Eye layer and insert a 
keyframe. 

7. Move the left eye the same distance as the right eye, and 
then create a motion tween between the first and last 
frames on the Left Eye layer. 

Figure 15 Tween menu 

Figure 16 Motion tween in the Timeline 
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Use a shape tween to animate the mouth 

Because you created the mouth by using one of the drawing tools (the Line tool) and have not converted the mouth 
to a symbol, it is still a shape. You can use a shape tween to animate the mouth. 

8. Select frame 37 on the Mouth layer and insert a 
keyframe. 

9. With the Selection tool, click on the Stage away from 
the mouth line to deselect it. Then drag the mouth line 
into a bigger smile. 

10. To create a shape tween between the first and last 
frames on the Mouth layer, click a frame between 
frames 1 and 37, and select Shape in the Tween menu in 
the Property inspector. 

Notice the frames containing the shape tween are now 
light green and contain a solid arrow running from the 
start frame to the end frame.  

10. Select File > Save. 

11. Select Control > Test Movie to see it play. 

Selecting Control > Test Movie exports a .swf file and 
plays it in a preview window. When the movie reaches 
the last frame, it loops back to frame 1 and plays again. 

12. Select File > Close to close the preview window. 

Create any additional animated facial features as you choose. 
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Publish your movie 
When you’re ready to deliver your movie to an audience, you can publish the Flash document (FLA file) for 
playback. The Publish command creates a Flash SWF file (playable with Flash Player) and an HTML document that 
inserts your Flash movie in a browser window. For viewers who do not have Flash Player installed, you can select to 
publish the FLA file in alternative file formats—GIF, JPEG, PNG, or QuickTime—with the HTML needed to 
display them in a browser window. 

When you publish HTML with your movie, Flash also creates a file called AC_OETags.js. This JavaScript file lets 
your SWF file play automatically in certain browsers (called active content-compliant browsers) that would 
otherwise require a site visitor to click to play your movie. To avoid this problem, upload AC_OETags.js to your 
site in the same location as the HTML file that hosts the movie. For more about this issue, visit 
www.adobe.com/go/activecontent.

1. Select File > Publish Settings to open the Publish 
Settings dialog box (Figure 17). 

2. Use the Formats tab to determine which file formats to 
output when you publish. 

3. Use the Flash tab to determine which Flash Player you 
are publishing to (Figure 18). If you think your 
audience might not have the latest player, you might 
want to select an older player from the Version menu. 

4. Select Generate Size Report to see a detailed report of 
size for each asset in your movie. 

5. Select Protect From Import to prevent anyone from 
importing your SWF file into Flash and converting it 
back to a FLA file. 

6. Select Compress Movie to reduce the file size of the 
exported movie. 

Figure 17 Publish Settings dialog box 

Figure 18 Flash tab of Publish Settings dialog box
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7. Use the HTML tab to control settings for the HTML file 
(Figure 19).

8. Deselect the Loop option if you want your movie to play 
through only one time and stop. 

9. To publish your movie, click the Publish button.

Figure 19 HTML tab of Publish Settings dialog 
box 
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Symbols, instances, and the library 

Symbols and instances 
A symbol is a graphic, button, or movie clip you create once in Adobe Flash CS3 and can use any number of times 
throughout your movie. Any symbol you create is automatically placed in a storage area called the library for the 
current document. 

An instance is a copy of a symbol located on the Stage. An instance can be different from its symbol in color, size, 
and function. To create an instance of a symbol, drag the symbol from the library onto the Stage. Once you have 
created an instance, you can use the Color options in the Property inspector to change its brightness, tint, alpha, or 
RGB color settings. 

Editing the symbol automatically updates all of its instances, but applying effects to an instance of a symbol updates 
only that instance. 

Using symbols offers a number of advantages. Symbols add interactivity to your documents. They save space and 
reduce the download time of your finished movie because Flash does not have to save duplicate information for each 
instance. For example, if you create an animated wheel symbol, you can use several instances of the symbol to 
create the wheels on a train. The result is a much smaller file than if you had created each wheel separately. Symbols 
also help you maintain consistency throughout your Flash document. For example, if you have buttons throughout 
your document, using symbols ensures that all buttons look alike. You can easily edit all instances of buttons in a 
document at once when you use symbols to create them. You can also use symbols to share content between 
different documents. 

When you create a new drawing in Flash, you’re creating a shape, not a symbol. You can convert any shape to a 
symbol by selecting it and then selecting Modify > Convert To Symbol. 

Libraries
The library is a container in each movie where Flash stores and organizes symbols, sounds, bitmap graphics, video, 
and other elements. The library is attached to the document you’re working on. To open the Library panel, select 
Window > Library (Figure 1). If you share your document with someone else, and they open it on their computer, 
they will see the same library objects. You can also open libraries from other documents by selecting File > 
Import > Open External Library. As your documents become more complex, you’ll find it helpful to use folders to 
sort your symbols into related groups within the library. 

Figure 1 Library panel 
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Types of symbols 
Flash has three types of symbols: graphic, button, and movie clip. 

Each symbol has a unique Timeline and Stage, complete with layers. When you create a symbol, you choose the 
symbol type, depending on how you want to use the symbol in your document. 

� Use graphic symbols for static images and to create reusable pieces of animation that are tied to the main 
Timeline. Graphic symbols operate in sync with the main Timeline. Interactive controls and sounds won’t work 
in an animation sequence contained in a graphic symbol. 

� Use button symbols to create interactive buttons that respond to mouse clicks, rollovers, and other site visitor 
actions. You define the graphics associated with various button states and then assign actions to a button 
instance.

� Use movie clip symbols to create reusable pieces of animation. A movie clip has its own Timeline that is 
independent from the main Timeline—think of it as a sub-Timeline nested inside the main Timeline. Movie 
clips can contain interactive controls, sounds, and even other movie clip instances. 

Creating symbols 
You create symbols in one of two ways: 

� Select Insert > New Symbol. This creates a new symbol to which you must add content. 

� Select an existing shape and select Modify > Convert To Symbol. 
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Frames and keyframes 
Frames define increments on the Timeline (Figure 1). The order in which frames appear on the Timeline determines 
the order in which they appear when a Flash document plays. You can arrange keyframes on the Timeline to edit the 
sequence of events in an animation. 

Keyframes are special frames in which you define a change in an animation, either by changing an object’s 
properties (such as its size or location) or by adding ActionScript to the frame. Keyframes let you produce animation 
without drawing each individual frame. Flash can tween, or automatically fill in, the frames between keyframes to 
produce animations. Blank keyframes are keyframes in which all previous frame content is cleared. 

A keyframe is indicated on the Timeline with a solid black circle. The frame where a keyframe span ends has a 
small white rectangle. A blank keyframe is indicated by an empty circle. 

Figure 1 Frames 

You can do the following with frames or keyframes: 

� Insert frames, keyframes, and blank keyframes. 

� Remove frames, keyframes, and blank keyframes. 

� Convert frames to keyframes or blank keyframes. 

� Drag frames and keyframes to a new location on the same layer or on a different layer. 

� Copy and paste frames and keyframes. 

Keyframe Frame Blank
keyframe 

End of 
keyframe span 
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How to create motion and shape tweens 

Overview of tweening 
Adobe Flash CS3 provides several methods for creating an animation sequence, including tweened animation and 
frame-by-frame animation. Frame-by-frame animation involves a series of keyframes with a different image in every 
frame. Although this can be useful for complex animations, Flash is capable of automatically creating animation by 
tweening images. The word tween comes from an animation technique in which an artist draws the starting point of 
a motion—such as a dog wagging its tail to the left—and the stopping point of the motion—a wag to the right. Then 
the artist has to draw all the stages in between to make the tail appear to move. To tween an element on the Stage in 
Flash, you set the starting and ending frames for the element, create a tween between those frames, and Flash 
automatically fills in the frames between. There are two types of tweens in Flash: motion tweens and shape tweens. 

Motion tweening 
You can use motion tweening to animate any of the following elements: 

� An instance of a symbol (graphic, button, or movie clip) 

� A grouped object (a collection of drawn shapes that have been grouped) 

� A text block 

When using a motion tween to animate an instance of a symbol, you can change the following properties: 

� Color (tint) 

� Alpha (fade or transparency) 

� Position 

� Size

For example, you can use a motion tween to create the effect of text floating across the Stage, but if you want the 
text to slowly fade as it moves across the Stage, you must first convert the text block to a symbol. You can then 
adjust the alpha value in the Property inspector to create the fade. 

1. Start Flash and open a new blank document. 

2. Draw a shape on the Stage or import an image by 
selecting File > Import > Import To Stage. 

Notice the shape appears in keyframe 1 of Layer 1. 

3. If the object is a drawn object, select the Selection tool 
and double-click the object to select it. 

If the object is an imported image, select the Selection 
tool and just click the object to select it. 

4. Select Modify > Convert To Symbol. 

The Convert To Symbol dialog box opens (Figure 1). 

 Note: You cannot apply motion tweens to shapes. To 
apply a motion tween, you must first convert the shape 
to a symbol. 

5. Type a new name for the symbol in the Name text box, 
select the Graphic option, and click OK. 

Figure 1 Convert To Symbol dialog box 
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6. Select frame 10. 

7. Select Insert > Timeline > Keyframe. (This will make 
the motion tween last for 10 frames.) 

Notice that when you insert a keyframe, Flash fills the 
area between the last frame (on the current layer) and 
the new keyframe with the same content (Figure 2).
Frames 1 through 10 all contain the new symbol. 

8. Make sure frame 10 is selected. This is the end frame for 
the motion tween. Select the instance of the symbol in 
frame 10; then make one or more of the following 
changes:

Color change: In the Property inspector, select Tint 
from the Color pop-up menu (Figure 3). Select 100% 
for the Tint Amount and change the color in the color 
box. 

Fading: In the Property inspector, select Alpha from the 
Color pop-up menu. Reduce the percentage of the Alpha 
Amount for more transparency. For example, an Alpha 
value of 0% makes the object disappear. 

Position: Use the Selection tool to move the object to a 
different position on the Stage. 

Size: Select the object. Then select Modify > 
Transform > Free Transform. Drag the object handles to 
increase size, decrease size, and rotate the object. 

9. Select frame 1 on the Timeline. 

10. In the Property inspector, select Motion from the Tween 
pop-up menu. 

In the Timeline, the tween is represented by a solid 
arrow on a blue background running from the start 
keyframe to the end keyframe (Figure 4). 

11. In the Property inspector (Figure 5), adjust one or more 
properties of the Motion tween: 

� Ease: Controls how fast the object starts or ends the 
motion tween. For example, a high number for Ease 
makes an object begin tweening quickly but end 
tweening slowly. 

� Rotate: Rotates the object clockwise or 
counterclockwise a designated number of times. 

� Scale: Keeps the proportions of the object equal 
when the tween resizes the object. 

� Orient to path: If you add a guide layer, the object 
is linked to the path drawn on the guide layer. 

� Sync: Starts and stops the tweening of all objects on
the Stage at the same time. 

� Snap: Keeps the tweened object aligned to an 
invisible grid to control spacing.

Figure 2 Inserted keyframe 

Figure 3 Color pop-up menu 

Figure 4 Motion tween in the Timeline 

Figure 5 Tween Property inspector 

Color pop-up menu Tint Amount 
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12. Select Control > Test Movie to test the movie. 

13. Select File > Close to close the preview window. 

14. To see all phases of the tween at the same time, click the 
Onion Skin Outline button at the bottom of the Timeline 
(Figure 6).

15. Drag the onion skinning frame handles (they appear as 
brackets with circles on them at the top of the Timeline) 
to span the frames in which the object appears. 

The steps of the tween are all visible on the Stage 
(Figure 7).

16. Turn off onion skinning. 

17. Save the movie.

Figure 6 Onion Skin Outline button 

Figure 7 Onion skinning visible 

Onion Skin Outline 

Common motion tween problems and solutions 

The tween you created was indicated on the Timeline by a solid arrow on a blue background. If the tween is not 
working, the arrow is dashed. There are several ways to fix a broken motion tween. 

Problem Solution 

No keyframe at beginning or ending of motion 
tween.

Remove the motion tween in the Property inspector (select 
any frame of the tween and select None in the Tween menu 
in the Property inspector). Then select the beginning or 
ending frame and select Insert > Timeline > Keyframe. Add 
the motion tween again. 

Objects in keyframes aren’t the same. Remove the motion tween in the Property inspector. Click 
the second keyframe (farther down the Timeline). Right-
click (Windows) or Control-click (Mac OS) and select  
Clear Keyframe. Make sure the first keyframe has the 
correct objects in it. Insert the second keyframe again and 
add the motion tween. 

The two keyframes contain objects that aren’t 
instances of symbols, grouped objects, or a text 
block. 

Remove the motion tween and clear the second keyframe. If 
necessary, convert objects in the first keyframe to symbols 
or remove them from the Stage. Add the second keyframe 
again and re-create the motion tween. 

More than one symbol is in the frame. Motion 
tweening will not occur on layers with more than 
one group or symbol. 

Remove the motion tween and place each symbol on a 
separate layer; then create separate motion tweens for each 
symbol on separate layers. 
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Shape tweening 
In Flash, a shape is a vector-based object or series of objects, such as anything you draw with the drawing tools. For 
a shape to be animated by shape tweening, it cannot be a grouped object, a bitmap, or a symbol. You can apply 
shape tweening to text, but you must first convert the text to a shape by breaking it apart. 

For example, you could create a motion tween that turns the word “elephant” into an image of an elephant. 

You can use a shape tween to: 

� Tween the shape of an object (morph from one shape to another) 

� Tween the color of an object (including a color with transparency) 

� Tween the position of an object on the Stage (much like a motion tween, but between shapes rather than 
symbols) 

� Tween text that has been broken apart 

� Tween a bitmap that has been broken apart (converted to a shape) 

You cannot use a shape tween to: 

� Tween grouped objects 

� Tween symbols 

� Tween text that has not been broken apart 

� Tween bitmaps that have not been broken apart 

Note: Shape tweens can use much more computer memory than motion tweens, so it is best to use shape tweens 
sparingly. It is also best to use simple shapes in shape tweens. 

In a shape tween, you can change the following properties: 

� Color (tint) 

� Alpha (fade) 

� Shape  
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To change the color or alpha of a shape, use the Color Mixer panel. 

1. Start Flash and open a new blank document. 

 Frame 1 in Layer 1 already contains a blank keyframe. 

2. Begin by adding a shape to the Stage: 

Drawn objects: Select a shape tool (rectangle or oval) 
and draw an object on the Stage. 

Text: Select the Text tool and type a word or phrase on 
the Stage. Then select the text and select Modify > 
Break Apart. This breaks the words into separate letters. 
With the letters still selected, select Modify > 
Break Apart again to convert the letters into shapes. 

Outside images: Select File > Import > Import To Stage 
to import an image. If the image is a bitmap, you must 
break it apart. If the image is a grouped vector drawing, 
you must ungroup it completely. To break apart a 
bitmap, select Modify > Break Apart. To ungroup an 
image, select Modify > Ungroup. 

Note: You might need to select Modify > Break Apart 
or Modify > Ungroup multiple times until the object 
becomes a shape, as indicated in the Property inspector. 

3. Select frame 10. 

4. Select Insert > Timeline > Keyframe.  

 This will make the tween last for 10 frames. 

5. Make sure frame 10 is still selected and make one or 
more of the following changes to your shape: 

Amorphous shape change: Click the Stage with the 
Selection tool to deselect the object. Bring the Selection 
tool close to the object to grab an edge. Drag the edge to 
change the shape of the object (Figure 7).

Different shape: To morph between your original shape 
and a new shape, delete the object in keyframe 10 and 
draw a new object. Note: Select Modify > Break Apart 
if the drawn object is not a shape. 

Text: To morph between your original shape and text, 
delete the object in keyframe 10 and type text on the 
Stage. Select Modify > Break Apart until the text block 
is a shape, as indicated in the Property inspector. 

Outside image: To morph between your original shape 
and a new image you import, delete the object in 
keyframe 10 and select File > Import to bring in another 
outside image. Select Modify > Break Apart to make the 
object a shape, if necessary. 

Figure 7 Change shape with Selection tool 
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6. Select frame 1 on the Timeline (on the current layer). 

This is your start frame for the animation. 

7. In the Property inspector, select Shape from the Tween 
pop-up menu (Figure 8). 

8. Adjust one or more properties of the Shape tween: 

Ease: Controls how fast the object starts or ends the 
shape tween. For example a high number for Ease would 
have an object begin tweening quickly but end the tween 
slowly.

Blend (Distributive): Creates an animation in which the 
intermediate shapes are smoother and more irregular. 

Blend (Angular): Creates an animation that preserves 
corners and straight lines in the intermediate shapes. 

9. Select Control > Test Movie to test the movie. 

10. Select File > Close to close the preview window. 

11. To see all phases of the tween at the same time, click the 
Onion Skin button at the bottom of the Timeline. 

12. Drag the frame handles (they appear as brackets with 
circles on them at the top of the Timeline) to span the 
first 10 frames of Layer 1. 

The steps of the tween are all visible on the Stage. 

12. Turn off onion skinning. 

13. Save the movie. 

14. Close the movie.

Figure 8 Tween Property inspector 

Shape tweens versus motion tweens 
The following table is helpful in deciding which type of tween to select when animating objects. 

Shape Group Symbol Text block Broken-apart text 

Shape tween yes no no no yes 

Motion tween no yes yes yes no 

6 How to create motion and shape tweens © 2007 Adobe Systems Incorporated 



Adobe Flash CS3 Project 5.1 guide 

How to get started with ActionScript 
ActionScript 3.0 is the scripting language of Adobe Flash CS3. You can use ActionScript to add complex 
interactivity, playback control, and data display to your application. For example, you might want to animate a 
picture of a boy walking. By adding ActionScript, you could have the animated boy follow the pointer around the 
screen, stopping whenever he collides with a piece of animated furniture. 

ActionScript is an object-oriented programming language. Object-oriented programming is a way to organize the 
code in a program, using code to define objects and then sending messages back and forth between those objects. 

You don’t have to be a programmer to take advantage of ActionScript (see “Using Script Assist mode” later in this 
guide). But the following concepts will help: 

� Class: The code that defines an object. This code consists of properties, methods, and events. Think of the 
blueprint of a house: you can’t live in the blueprint, but you need it so you can build the house. You use 
classes to create objects.

� Object: An instance of a class. When you instantiate an object (create an instance of it), you declare what 
class it is created from and set its properties. You can create as many objects as you want from a single 
class—if you have a bicycle class, you can create many bicycle objects, each with its own properties 
(one bicycle might be red while another might be green). 

� Property: One of the pieces of data bundled together in an object. A property helps define an object—it 
provides the object’s characteristics. A song object might have properties named melody and title.
You set the properties of an object when you create the object, but you can change them later as needed. A 
property is a variable that belongs to an object. 

� Variable: A name that represents a value in the computer’s memory. As you write code, you write the 
variable’s name as a placeholder for the value. This allows you to write code even if you don’t know all the 
possible values a visitor might provide. If you create a variable firstName, you can tell your program to 
display the visitor’s first name without knowing in advance what the visitor’s first name is. 

� Method: An action that can be performed by an object. For example, the class horse might have a method 
called gallop(). When the method gallop() is called, it shows an animation of the horse galloping 
from one point to another. 

� Function: A block of code that carries out specific tasks and can be reused in your program. For example, 
you might create a function called checkEmail() to verify that text typed by a visitor is a valid e-mail 
address. Each time a visitor provides an e-mail address, you can call checkEmail() to make sure the 
visitor has provided text that can actually be used as an e-mail address. If you ever want to update the 
function, you only have to do it once instead of in each place where e-mail addresses must be validated. 
You can also think of a method as a function attached to an object. 

� Event: Something that happens in a Flash movie that ActionScript is aware of and can respond to. Many 
events are related to user interaction—for example, a user clicking a button or pressing a key on the 
keyboard. The technique for specifying certain actions that should be performed in response to particular 
events is known as event handling.

If you’ve worked with symbols in Flash, you’re already used to working with objects. Imagine you’ve defined a 
movie clip symbol—say a drawing of a rectangle—and you’ve placed a copy of it on the Stage. That movie clip 
symbol is also an object in ActionScript; it’s an instance of the MovieClip class. The main timeline of a Flash movie 
also belongs to the Movie Clip class. 

You can modify various characteristics of any movie clip. When a movie clip is selected, the Property inspector 
shows some of the characteristics you can change, such as its X coordinate or its width. Or you can make color 
adjustments such as changing the clip’s alpha (transparency). Other Flash tools let you make more changes, such as 
using the Free Transform tool to rotate the rectangle. All of the ways you can modify a movie clip symbol in the 
Flash authoring environment are also things you can do in ActionScript. In ActionScript, you use the methods of the 
MovieClip class to manipulate or change the properties of your movie clip. 
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For more about object-oriented programming, see Programming ActionScript 3.0, “Object-oriented Programming in 
ActionScript” (in Flash, select Help > Flash Help). 

Using Script Assist mode 
You can add ActionScript in the authoring environment by using the Actions panel (Figure 1). The Actions panel 
provides Script Assist mode to simplify the coding process. 

Parameters area 

Actions toolbox 

Script Assist button 

Script pane 

Script navigator 

Figure 1 Actions panel in Script Assist mode 

In Script Assist mode, you can add ActionScript to your Flash document without writing the code yourself. You 
select actions from the Actions toolbox and set the options for each action in the parameters area. You must know a 
little about what functions to use to accomplish specific tasks, but you don’t have to learn syntax (the grammar of 
ActionScript). Many designers and nonprogrammers use this mode. 

One of the first things to learn is how to stop your movie at a certain spot. You will also learn how to send the 
playhead to a particular frame in the movie. 
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Using ActionScript to stop a movie 

1. Start Flash and open a movie. Create a layer in your 
movie named actions. In the frame that corresponds to 
the end of your movie, insert a new keyframe. 

2. Select Window > Actions to display the Actions panel. 

3. If you don’t see the parameters area in the Actions 
panel, click the Script Assist button in the upper-right 
corner (Figure 2).

 Classes are organized into packages. You want to add a 
stop() action to a movie clip (in this case, your 
timeline is the movie clip), so you must locate the 
Movie Clip class. The Movie Clip class is part of the 
Flash.Display package. 

4. In the Actions toolbox on the left side of the Actions 
panel, scroll down and click the Flash.Display package 
to display the classes it contains. 

5. Scroll down again to find the Movie Clip class and click 
to expand it (Figure 3).

6. Click Methods to view the methods available for the 
Movie Clip class. 

7. Scroll down to the Stop method. Do one of the 
following:  

� Double-click the Stop method. 

� Drag the Stop method into the Script pane. 

 Code for applying the Stop method appears in the Script 
pane (Figure 4). The first line (import
flash.display.MovieClip();) imports the 
code necessary for the Movie Clip class. The second line 
is the Stop action itself. The red code not_set_yet
indicates you should use Script Assist to finish the code.

8. Click in the Object field in the parameters area of the 
Actions panel. 

 The Insert Target Path button is now active. The target 
path helps you locate the object you are trying to 
control. 

Figure 2 Actions panel 

Figure 3 Movie Clip class 

Figure 4 Stop method 

Script Assist button 

Insert Target Path button 
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9. Click the Insert Target Path button. 

 The Insert Target Path dialog box appears (Figure 5).

10. Select the Relative option and click Root. 

 This sets the target path to this.

11. Click OK to close the Insert Target Path dialog box. 

 The completed script for the Stop method appears in the 
Script pane (Figure 6). This code will cause your movie 
to stop playing at the end of the movie, frame 40. 

Note: In ActionScript, this is used the same way that 
you would refer to yourself as “me” instead of using 
your full name. Remember that the main timeline is an 
instance of the MovieClip class. In Figure 6, Flash uses 
this to refer to the movie clip that frame 40 belongs to.

12. Close the Actions panel. 

Figure 5 Insert Target Path dialog box 

Figure 6 Stop method applied to frame 40 

Frame number 

Event handling 

The technique for specifying certain actions that should be performed in response to particular events is known as 
event handling. Event handling consists of three important elements: 

� The event source: Which object will trigger the event? For example, which button will be clicked, or which 
Loader object is loading the image? 

� The event: What is going to happen, what interaction do you want to respond to? Identifying the event is 
important, because an object can trigger (and listen for) several events. 

� The response: What action(s) do you want performed when the event happens? 

When an ActionScript program is running, Adobe Flash Player just sits and waits for certain events to happen, and 
when those events happen, the player runs the specific ActionScript code you’ve specified for those events. For the 
program to know what events are important, you must create an event listener. An event listener is a function Flash 
Player executes in response to specific events. 

Adding an event listener is a two-step process: 

� First, you create a function or class method for Flash Player to execute in response to the event. This 
function is sometimes called the listener function.

� Second, you use the addEventListener() method to connect the listener function with the target of the event. 
The addEventListener() function tells Flash what object to listen to, what event to listen for, and what 
function to execute in response. 
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Using ActionScript to go to another frame 

1. Create a button users can click to go to a particular 
frame in your movie. Make sure you place the button on 
the Stage (Figure 7).

2. Select the button and use the Property inspector to give 
the button a unique instance name (Figure 8).

3. In the main timeline of your movie, create a layer named 
actions.

4. Create a keyframe in the actions layer that corresponds 
to the keyframe where your button first appears on the 
Stage. Select this keyframe in the actions layer. 

Note: If your button doesn’t appear in this frame, Flash 
will generate an error message because you are referring 
to an object that isn’t on the Stage yet. 

5. Select Window > Actions to display the Actions panel. 

6. If you don’t see the parameters area in the Actions 
panel, click the Script Assist button. 

7. In the Actions toolbox on the left side of the panel, 
select the AddEventListener method from the 
IEventDispatcher class. 

To find the AddEventListener method, open 
flash.events, and then open IEventDispatcher. 

8. Double-click the AddEventListener method to add it to 
the Script pane (Figure 9).

9. Click in the Object field in the parameters area of the 
Actions panel. 

 The Insert Target Path button is now active. 

10. Click the Insert Target Path button. 

 The Insert Target Path dialog box appears (Figure 10).

11. Select the Relative option and select the instance name 
of your button. Click OK to close the dialog box. 

 The event listener is attached to the instance of your 
button (Figure 11). You must now select an event to 
listen for. 

Figure 7 Button instance 

Figure 8 Button instance 

Figure 9 AddEventListener method in the Actions 
toolbox 

Figure 10 Insert Target Path dialog box 

Figure 11 Event listener code in the Script pane 

Instance name 
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12. In the Actions toolbox on the left side of the panel, 
select the CLICK property from the MouseEvent class 
(Figure 12).

To find the CLICK property, open Flash.Events, and 
then open MouseEvent. 

13. In the Script pane, select the AddEventListener() line to 
display the parameters for this method. Then, in the 
parameters area, click in the Type field. 

14. In the Actions toolbox, double-click the CLICK 
property. 

Script Assist adds the property to your code as 
MouseEvent.CLICK (Figure 13).

 Now your code will listen for a click on the button. To 
tell the event listener how to respond when that click 
occurs, you will create a function. 

15. In the parameters area, type a name for your function in 
the Listener field. You can use any name you like, but 
make sure the name of the function is unique and 
contains no spaces (Figure 14).

 The function name appears in the Script pane as you 
type. You have named the function, but you haven’t 
created it yet. 

16. In the Actions toolbox, select the function keyword 
from Language Elements. 

To find the function keyword, expand Language 
Elements. Then expand Statements, Keywords & 
Directives, and expand Definition Keyword. 

17. Double-click the function keyword in the Actions 
toolbox. 

 The code for creating a function appears in the Script 
pane (Figure 15).

18. In the parameters area of the Script pane, type the name 
of your function in the Name field. 

Note: The function name must be typed exactly as you 
typed it for the AddEventListener function in step 15. 
Function names are case-sensitive. 

19. In the parameters area of the Script pane, type 
event:MouseEvent in the Parameters field. 

 In this field, you are naming a variable (event) and 
indicating what type of variable it is (MouseEvent).

Figure 12 CLICK property in the Actions toolbox

Figure 13 CLICK property in the Script pane 

Figure 14 Function name in the Listener field 

Figure 15 Function code 
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20. In the parameters area of the Script pane, select Void 
from the Type pop-up menu. 

 Some functions return a value when called. The 
keyword void indicates that this function does not 
return a value. 

 Now you can tell the function what you want it to do 
when the CLICK event occurs. 

21. In the Actions toolbox on the left side of the panel, 
select the GotoAndPlay method for the Flash.Display 
class (Figure 16).

To find the GotoAndPlay method, expand 
Flash.Display, and then expand MovieClip. 

22. Select the function in the Script pane and double-click 
the GotoAndPlay method in the Actions toolbox. 

 The method is added to the function (Figure 17).

23. Click in the Object field in the parameters area of the 
Actions Panel. 

 The Insert Target Path button is now active. 

24. Click the Insert Target Path button to display the Insert 
Target Path dialog box. 

25. Select the Relative option and select the movie clip you 
want to play when the button is clicked. If you want the 
movie in the main timeline to play, select Root to set the 
target path to this.

26. Click OK to close the Insert Target Path dialog box. 

27. In the Frame field, type the number of the frame you 
want to send the playhead to. For example, if you want 
the movie to start from the beginning, type the number 1
to play the movie’s first frame. 

28. Close the Actions panel. 

29. Save the movie. 

30. Select Control > Test Movie to test the movie. 

31. Select File > Close to close the preview window.

Figure 16 GotoAndPlay method 

Figure 17 GotoAndPlay method in the Script pane

For more about ActionScript, see Programming ActionScript 3.0, “Getting Started with ActionScript” (in Flash, 
select Help > Flash Help). 
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How to create a button symbol 

Button symbols 
Buttons give visitors a way to control parts of a movie. You can use button symbols to create interactive buttons that 
respond to mouse clicks, rollovers, or other visitor interaction. Button symbols are four-frame interactive movie 
clips. The first three frames display the button’s three possible states: Up, Over, and Down. The fourth frame, Hit, 
defines the active area of the button. The Timeline for a button doesn’t play like other movies; it reacts to pointer 
movement and actions by jumping to and displaying the appropriate frame. 

You can create the image that represents your buttons in several ways. For example, you can use an existing graphic 
as the button, or you can create a shape by using the drawing tools. 

Create a button 
You will create a new button symbol that contains two layers. One layer will contain a shape representing the 
background of the button. The second layer will include a text label for the button. You will change the background 
and text label in the Over and Down states of the button to create the rollover effect. 

1. Start Adobe Flash CS3 and create a new Flash file 
(ActionScript 3.0). 

2. Select Insert > New Symbol. 

The Create New Symbol dialog box appears (Figure 1).

3. Select Button as the behavior type, name the button, and 
click OK. 

You are now in symbol-editing mode and viewing a 
separate Timeline for the button symbol. The Up frame 
contains a keyframe (Figure 2). 

Each frame on the Timeline of a button symbol has a 
specific function: 

� Up state: Represents the button’s appearance 
whenever the pointer is not over the button. 

� Over state: Represents the button’s appearance 
when the pointer is over it. 

� Down state: Represents the button’s appearance as 
it is clicked. 

� Hit state: Defines the area that will respond to a 
mouse click. This area will be invisible in the 
published movie. 

4. Make sure the Up frame is selected. 

5. Use the drawing tools to create a shape for your button. 
Use the Property inspector to set the fill and stroke 
colors for the Up state of the button. 

6. Select the Over state and select Insert > Timeline > 
Keyframe to add a keyframe. 

 Adding this keyframe copies the button graphic from the 
Up frame to the Over frame. 

Figure 1 Create New Symbol dialog box 

Figure 2 Button frames: Up, Over, Down, Hit 
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7. Select the Over keyframe and use the Selection tool to 
select the button. 

8. Change the fill or stroke color of the button shape. 

When visitors roll over the button, the button will appear 
as you see it in the Over frame. 

9. Insert keyframes in the Down and Hit frames of the Text 
layer.

This copies the button graphic from the Over frame to 
the Down and Hit frames. 

10. Insert a new layer and name it Text. 

11. Select the Up frame of the Text layer. 

This frame already contains a keyframe. 

12. Use the Text tool to type text on the button shape. 

13. Use the Property inspector to adjust the font, size, and 
color of the text so it fits nicely on your button shape. 

14. Use the Selection tool or the Up, Down, Left, and Right 
Arrow keys to position the text on the button shape. 

15. Insert a keyframe in the Over frame of the Text layer. 

16. Select the text and use the Property inspector to change 
some feature of the text in the Over frame, such as color.

17. Insert a keyframe in the Down frame. If you want the 
text to change appearance when the button is clicked, 
edit the appearance of the text in the Down frame. 

The Timeline should now appear as it does in Figure 3.

Now you can insert an instance (copy) of the button 
symbol into the main Timeline of your movie. 

18. Click Scene 1 to exit symbol-editing mode and return to 
the main Timeline. 

19. Select Window > Library to display the Library panel. 

The new button symbol appears in the Library panel 
(Figure 4).

 Note: You must select the symbol in the library to see 
the symbol in the preview pane. 

20. Drag the button symbol from the library onto the Stage. 

21. Select Control > Test Movie to test the movie. 

 When you roll over the button with the pointer, you see 
the changes you defined in the Over frames for the 
button. If you edited the Down state of the button, this 
will be visible when you click the button. 

22. Select File > Close to close the preview window. Then 
save your movie.

Figure 3 Button Timeline 

Figure 4 Button in library 
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Adding sound to a button 

You can also add sounds to the button so visitors hear a sound when they interact with the button. 

1. Use the Selection tool to double-click the button to enter 
symbol-editing mode for the button. 

2. Insert a new layer and name it Sound. 

3. Select File > Import > Import To Library to import a 
short sound into the library.  

 You can acquire royalty-free sounds from sites such as 
www.flashkit.com.

4. On the Sound layer, add a keyframe to correspond with 
the button state to which you want to add a sound. 

 For example, to play a sound when visitors roll over the 
button, add the keyframe to the Over state. 

5. Click the new keyframe. 

6. Make sure the Property inspector is visible. (Select 
Window > Properties.) 

7. In the Property inspector, select a sound file from the 
Sound pop-up menu (Figure 5). 

8. Select Event in the Sync pop-up menu. 

 The sound will play when visitors interact with the 
button. 

Figure 5 Frame Property inspector 

Sound pop-up menu 
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Adding control with actions 

Right now the button looks great, but it doesn’t perform any action. You can remedy this by adding ActionScript 
code to your movie. 

Buttons give visitors control over the movie. You can create code for your buttons to stop the movie, stop sounds, 
restart the movie (after stopping it), or jump to different frames within the movie and begin playing. You can add 
actions to any instance of the button symbol you’ve placed in your movie. 

1. Select the button instance to which you want to add an 
action. Use the Instance Name text box in the Property 
inspector to give the button a unique instance name 
(Figure 6).

2. In the main timeline of your movie, create a new layer 
named Actions.

3. Create a keyframe in the actions layer that corresponds 
to the keyframe where your button first appears on the 
Stage. Select this keyframe in the actions layer. 

Note: If your button doesn’t appear on this frame, Flash 
generates an error message when you publish the movie 
because the ActionScript you include on this frame 
refers to an object that isn’t on the Stage yet. 

4. Select Window > Actions to display the Actions panel. 

5. If you don’t see the parameters area in the Actions 
panel, click the Script Assist button. 

6. In the Actions toolbox on the left side of the panel, 
select the AddEventListener method for the 
IEventDispatcher class. 

To find the AddEventListener method, expand 
Flash.Events, and then expand IEventDispatcher. 

7. Double-click the AddEventListener method to add it to 
the Script pane (Figure 7). 

8. Click in the Object field in the parameters area of the 
Actions panel. 

 The Insert Target Path button is now active. 

9. Click the Insert Target Path button. 

 The Insert Target Path dialog box appears (Figure 8). 

10. Select the Relative option and select the instance name 
of your button. Click OK to close the dialog box. 

Figure 6 Button Property inspector 

Figure 7 AddEventListener method in the Actions 
toolbox 

Figure 8 Insert Target Path dialog box 

Instance Name 
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11. In the Actions toolbox on the left side of the panel, 
select the CLICK property from the MouseEvent class 
(Figure 9).

To find the CLICK property, expand Flash.Events, and 
then expand MouseEvent. 

12. In the Script pane, select the AddEventListener() line to 
display the parameters for this method. Then, in the 
parameters area, click in the Type field. 

13. In the Actions toolbox, double-click the CLICK 
property. 

Script Assist adds the property to your code as 
MouseEvent.CLICK (Figure 10). 

14. In the Listener field in the parameters area, type a name 
for the function that should execute when the button is 
clicked. You can use any name you like, but make sure 
the name of the function is unique and contains no 
spaces.

 The function name appears in the Script pane as you 
type. You have named the function, but you haven’t 
created it yet. 

15. In the Actions toolbox, select the function keyword 
from Language Elements.  

To find the function keyword, expand Language 
Elements. Then expand Statements, Keywords & 
Directives, and expand Definition Keyword. 

16. Double-click the function keyword in the Actions 
toolbox. 

 The code for creating a function appears in the Script 
pane. 

17. In the parameters area of the Script pane, type the name 
of your function in the Name field. 

Note: You must type the function name exactly as you 
typed it for the AddEventListener function. Function 
names are case-sensitive. 

18. In the parameters area of the Script pane, type 
event:MouseEvent in the Parameters field (Figure 11).

 In this field, you are naming a variable (event) and 
indicating what type of variable it is (MouseEvent).

19. In the Actions toolbox on the left side of the panel, 
select the StopAll method for the SoundMixer class. 

To find the StopAll method, expand Flash.Media, and 
then expand SoundMixer. 

Figure 9 CLICK property in the Actions toolbox 

Figure 10 CLICK property in the Script pane 

Figure 11 Function code in the Script pane 
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20. Select the function in the Script pane and double-click 
the StopAll method in the Actions toolbox. 

 The method is added to the function (Figure 12). 

21. Save the movie. 

 Now when visitors click the button, all sounds currently 
playing in the movie will stop. 

Figure 12 StopAll method in the Actions panel 

For more about ActionScript, see Programming ActionScript 3.0, “Getting Started with ActionScript” (in Flash, 
select Help > Flash Help). 
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Analyzing Flash on the web 
Student name: ________________________________________________ Date: _______________________ 

Examine some websites that use Adobe Flash CS3 to see examples of the techniques designers use to target a variety 
of audiences. Use this worksheet to record your observations. 

URL: _______________________________________________________________________________________ 

Name of the site: ______________________________________________________________________________ 

What is the main type of audience the site is targeting? How does the site target this audience? 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

Identify the following Flash techniques and explain what part of the site uses them: 

Motion tweens 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

Shape tweens 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 
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Movie clips 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

Buttons 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

Sound (How many sounds do you hear? How many times does the sound seem to loop?) 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

stop actions 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

go to and play actions 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 
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Combinations of symbols (such as buttons that contain animated movie clips) 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

Challenge:

For the complicated effects you see, suggest combinations or types of technical techniques that might be involved to 
create them. 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

Describe a surprising technique. 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

Describe a challenging technique. 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 
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Describe unidentified techniques. 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

Describe a creative design. 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 

____________________________________________________________________________________________ 
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Analyzing Flash on the web 
This sample analysis of a Flash website illustrates some techniques designers use to target a specific audience. 

URL: georgewashington.si.edu/

Name of the site: George Washington: A National Treasure

What is the main type of audience the site is targeting? How does the site target this audience? 

The main audience is teachers who might use the information on this site for a unit on George Washington, history, 
culture, or art. 

Identify the following Flash techniques and explain what part of the site uses them: 

Motion tweens 

When you launch the site, the white and red bars that expand and contract are a motion tween, as is the white star 
that appears. 

Shape tweens 

The white star that turns into the profile of George Washington is possibly a shape tween. 

Movie clips 

The rotating star that appears when your pointer is over the words “Explore the Portrait” is a movie clip. 

Buttons 

After you enter the portrait and click “Explore the Portrait,” the boxes at the top of the portrait, labeled Symbolic, 
Biographic, and Artistic, are all buttons. The numbers that appear on the portrait are also buttons. 

Sound (How many sounds do you hear? How many times does the sound seem to loop?) 

There are no sounds in the portrait. 

stop actions 

There is probably a stop action placed after the red and white stripes complete their motion tweens, to hold visitors 
at a screen before they decide to enter the portrait. 

go to and play actions 

There is most likely a go to and play action set on each of the main buttons over the portrait and the numerical 
buttons on the portrait. 

Combinations of symbols (such as buttons that contain animated movie clips) 

The “Enter the Portrait” button on the initial screen is a combination of a button and a movie clip, because the 
movie clip appears only when the pointer is over the button. 

© 2007 Adobe Systems Incorporated Analyzing Flash on the web 1



Activity 5.2 guide Adobe Flash CS3  

Challenge:

For the complicated effects you see, suggest combinations or types of technical techniques that might be involved in 
creating them. 

When the pointer rolls over one of the numbers on the portrait, these buttons fade all other parts of the image out 
and highlight the section of the image to which the number is attached. These buttons most likely contain an action 
that calls a movie clip to begin playing when the Over state is reached on the button. The movie clip fades out all 
aspects of the picture except the aspect related to the number you select. 

Describe a surprising technique. 

The magnifying glass is a surprising technique that adds to the overall feel of the site. Drag the pane up from the 
bottom of the portrait to magnify the portion of the portrait under the pane. 

Describe a challenging technique. 

The magnifying glass is a challenging technique. It most likely involves the use of programming with ActionScript. 

Describe unidentified techniques. 

It is difficult to tell how the magnifying glass might be achieved. 

Describe a creative design. 

A creative effect is the fading out and zooming in on aspects of the portrait when you click a number button. 
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How to produce Flash video for use on the web 
Adobe Flash CS3 provides a number of options for importing and publishing video with a Flash movie. 

You can import the following video formats if QuickTime 7 or higher is installed (Windows and Mac OS): 

� Audio Video Interleaved (.avi) 

� Digital Video (.dv) 

� Motion Picture Experts Group (.mpg or .mpeg) 

� QuickTime Movie (.mov) 

You can import the following file formats if DirectX 9 or later is installed (Windows only):  

� Audio Video Interleaved (.avi) 

� Motion Picture Experts Group (.mpg or .mpeg) 

� Windows Media File (.wmv, .asf) 

Deploying video 
Flash has three basic options for producing video: 

Progressive download: Flash creates a Flash video file that downloads from a regular web server and plays within 
the published SWF file. 

Embedded video: Flash converts video to Timeline frames. The video is contained entirely within the published 
SWF file. 

Stream from Adobe Flash Media Server or Flash Video Streaming Service: Although both of these options produce 
the overall best performance, they require either the Flash Media Server or a subscription to a Flash Video 
Streaming service. See the Adobe website for more information, www.adobe.com.

Using progressive download 

1. Open an existing Flash document or create and save a 
new Flash document. 

 Note: It is important that you save the Flash document 
before you begin the video import process. 

2. Select a keyframe on the layer in which you wish to 
import the video. 

 This is where the video player will be located once the 
video import has completed. 

3. Select File > Import > Import Video. 

 The Import Video wizard opens (Figure 1).

4. Enter a location for the video file you wish to import.  

 The video file can be located either on your computer or 
on the Internet. 

Figure 1 Import Video wizard, Select Video page
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5. Click Next. 

 The Deployment page of the Import Video wizard opens 
(Figure 2).

6. Select Progressive Download From A Web Server. 

Note: This is the preferred method for using video with 
Flash if use of Flash Media Server is not possible. 

7. Click Next. 

 The Encoding page of the Import Video wizard opens 
(Figure 3).

Note: If you are importing a Flash video file, then this 
step has already been done and the Skinning page will 
open.  

8. Select an encoding method based on the Flash Player 
version you intend to publish content for and the data 
rate at which you want your video content to be 
encoded. 

 Each method produces a different file size. Typically 
larger files provide higher quality, but performance may 
suffer.

Note: Progressive download works with Flash Player 7 
or later. 

9. Click Next.  

The Skinning page of the Import Video wizard opens 
(Figure 4).

The video’s skin determines the location and appearance 
of the video controls. Visitors will see this skin when 
Flash plays the video. 

10. Select a skin from the Skin pop-up menu. 

11. Select a skin color from the Color picker. 

12. Click Next. 

The Finish Video Import page of the Import Video 
wizard opens. This page confirms the location of the 
original video file and the new Flash Video file. 

Figure 2 Import Video wizard, Deployment page 

Figure 3 Import Video wizard, Encoding page 

Figure 4 Import Video wizard, Skinning page 
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12. Click Finish. 

The Flash Video encoder runs. When the encoder 
finishes running, an FLVPlayback object appears on the 
Stage (Figure 5). 

13. Select Control > Test Movie to see it play. 

The video plays in the Flash Player window. Observe 
that you can use the controls to stop, pause, fast forward, 
rewind, and change the volume of the video. 

14. Select File > Close to close the preview window.

15. Open the folder in which you have saved the Flash 
document. 

 Observe that this folder now contains two new files, an 
FLV file and a SWF for the video’s skin. (The skin will 
be called something like MojaveOverAll.swf.) When 
you publish your Flash document, both of these files 
need to be copied to the same location as the Flash 
document.

Figure 5 FLVPlayback object on Stage 

Embedding video within SWF files 

When you select the embedded video option, Flash converts video to Timeline frames. When the SWF file is 
published, the video is fully contained in that file; unlike progressive download, it requires no external file, and so is 
easier to deploy. However, because embedded video often has problems with audio synchronization after 
120 frames, Adobe recommends embedded video in only three cases: 

� When you want visitors who have Flash 5 to be able to view your video 

� When you must have one single file that encapsulates the video and the Flash content 

� When your video clip is less than 5 seconds long 

These situations are not common. In all other situations, embedded video is not recommended. 
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How to import sound 
In Adobe Flash CS3, you can import sound and video to integrate them into the Timeline. You can create media-rich 
content with very precise control. 

Importing sound 
You can use sound for many purposes in Flash. Some examples include soundtracks, narration, and sound effects 
that complement objects such as rollover buttons. 

You can import the following sound file formats into Flash: 

� WAV (Windows only) 

� AIFF (Mac OS only) 

� MP3 (Windows or Mac OS) 

If you have QuickTime 4 or later installed on your system, you can import these additional sound file formats: 

� AIFF (Windows or Mac OS) 

� Sound Designer II (Mac OS only) 

� Sound Only QuickTime Movies (Windows or Mac OS) 

� Sun AU (Windows or Mac OS) 

� System 7 Sounds (Mac OS only) 

� WAV (Windows or Mac OS) 

When you import a sound file, it’s placed in the library. Then you can drag an instance (copy) of the sound onto the 
Stage. Sound files must be tied to keyframes. 

You can synchronize a sound to your movie in several ways (using the Sync pop-up menu in the Property inspector): 

� Event: An event sound plays when the playhead reaches the first keyframe containing the sound. It plays in 
its entirety, independent of the Timeline, even if the movie stops. If a different instance of the same sound 
is started, the sounds will overlap. 

� Start: The same as Event, except that if the sound is already playing, no new instance of the sound will 
begin playing. 

� Stop: Silences the specified sound. 

� Stream: Forces the movie to keep pace with the sound. If Flash can’t draw animation frames quickly 
enough, it skips frames. Unlike event sounds, stream sounds stop if the movie stops. Stream sounds can 
also produce a much smaller file size, although their quality tends to be poorer than event sounds. 
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Import a sound 

1. Start Flash and open a document. 

2. Insert a new layer. 

3. Double-click the new layer name, and rename it Sound. 

4. Select File > Import > Import To Library. 

The Import dialog box opens (Figure 1).

5. Locate a sound file, select it, and click Open. 

Note: You can download free music loops and sound 
effect clips at www.flashkit.com, for example. 

6. Select frame 1 on the Sound layer. 

7. Make sure the Library panel is open. (If not, select 
Window > Library.) 

The sound appears in the Library panel. To preview the 
sound, click the Play button in the preview (upper) pane 
of the Library panel (Figure 2). 

 Note: You must select the sound to see the waveform of 
the sound in the preview pane. 

8. Drag the sound file from the Library panel onto the 
Stage.

 Note: The Sound layer must contain enough frames to 
play the entire sound. For example, if your movie is set 
for 12 frames per second and your sound is 2 seconds 
long, the Sound layer must contain at least 24 frames. If 
you are adding sound to an existing movie, your movie 
might already be long enough to accommodate the 
sound. 

9. If necessary, add frames to the Sound layer. To do this, 
click a frame down the Timeline for the Sound layer, 
such as frame 24 for a 2-second movie at 12 fps, and 
select Insert > Frame. 

 The sound does not appear on the Stage but does appear 
on the Timeline as a waveform (Figure 3).

 Note: Press the F5 key to insert a frame. Press Shift-F5 
to delete a frame. 

Figure 1 Import dialog box 

Figure 2 Library panel 

Figure 3 Sound in Timeline 

Play button 

Editing sound settings 

Through the Property inspector, you can change settings for the sound, including making the sound fade in and fade 
out. 

10. Select the first keyframe and adjust the settings for the 
sound in the Property inspector (Figure 4).

Figure 4 Sound Property inspector 
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Effect: Choose from previously created effects such as 
Fade In, Fade Out, keeping sound in only one channel 
(left or right), or fading sound from one channel to the 
other (Figure 5). Choosing Custom will open a sound-
editing window where you can create your own fading 
effects (Figure 6). In the sound-editing window, called 
the Edit Envelope, adjust the sound handles to control 
sound volume in each channel. 

Sync: Choose Event, Start, Stop, or Stream. 

Loop: Set the number of times to have the sound replay.

Figure 5 Effect pop-up menu 

Figure 6 Edit Envelope dialog box 

Sound compression 
Sound files can drastically increase the file size of your movies. One way to control this is to set the compression for 
the sounds in Flash.

1. Make sure the Library panel is open, and select the 
sound file. 

2. Click the Properties button in the Library panel 
(Figure 7).

The Sound Properties dialog box opens (Figure 8).

3. Choose a compression method from the Compression 
menu and click OK. 

ADPCM: This method sets the compression for 8-bit 
and 16-bit sound data. Use this when you export short 
event sounds such as button clicks. 

MP3: This method offers good compression and sound 
fidelity for longer stream sounds such as music tracks. 

Raw: This resamples the file but does not perform any 
compression. 

Speech: A good compression to use for speech sound 
files.

4. Save the movie. 

5. Select Control > Test Movie. 

Figure 7 Library Properties button 

Figure 8 Sound Properties dialog box 

Properties button 
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How to use guides and rulers 

Using guides 
You can drag horizontal and vertical guides from the rulers onto the Stage when the rulers are displayed. You can 
move guides, lock guides, hide guides, and remove guides. You can also snap objects to guides and change the guide 
color and snap tolerance (how close objects must be to snap to a guide). Adobe Flash CS3 enables you to create 
nested Timelines (i.e., movie clips within the main movie). Guides appear on the Stage only when the Timeline in 
which they were created is active. 

To create a guide: 

1. Make sure rulers are visible by selecting View > Rulers. 

2. Click on a ruler and drag toward the Stage (Figure 1). 

 A guide appears as you drag. 

3. Release the mouse button at the point you wish to locate 
the guide (Figure 2).

Figure 1 Drag a ruler 

Figure 2 Guide on Stage 

To lock or unlock guides: 

� Select View > Guides > Lock Guides. 

 This command toggles between locking and unlocking 
guides. When guides are locked, they won’t respond to 
clicking or dragging, so that you won’t accidentally 
move them when you are working with objects on the 
Stage. However, you can still create new guides. 

Note: You can also use the Lock Guides option in the 
Guides dialog box (View > Guides > Edit Guides). For 
more information, see the section titled Changing guide 
properties at the end of this guide. 

To view or hide the drawing guides: 

� Select View > Guides > Show Guides. 

To move a guide: 

� Make sure guides are not locked. With the Selection 
tool, click anywhere on the guide and drag the guide to 
the desired place on the Stage. 

To remove a guide: 

� With guides unlocked, use the Selection tool to drag the 
guide to the horizontal or vertical ruler. 
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Using guides to position objects on the Stage 

1. Select View > Snapping > Snap To Guides. 

2. Drag the edge of an object toward a guide. 

When you get close to the guide, the object snaps to it 
(Figure 3).

3. Release the mouse. 

 The object remains snapped to the guide. 

 You can use guides to line up different objects 
(Figure 4). Guides are especially useful for aligning 
objects on different layers. 

Figure 3 Snap object to grid 

Figure 4 Aligning objects with guides 

Changing guide properties 
You can change guide colors, set guide snapping properties, and lock guides. 

1. Select View > Guides > Edit Guides. 

 The Guides dialog box opens (Figure 5).

2. Click the Guides Color control to change guide colors. 

3. Select Lock Guides to lock guides in position. 

4. Click OK to close the Guides dialog box. 

Figure 5 Guides dialog box 
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How to create masks 
In Adobe Flash CS3, a mask is a special type of layer that lets you reveal select parts of another layer. For example, 
if you want to show people walking around inside a house, and you want them to be visible when they pass by a 
window but invisible otherwise, you can use a mask. You can use masking for techniques such as creating a 
spotlight or showing pictures behind images. 

Creating a mask 

1. Start Flash and open a document. 

2. Import an image to the Stage. 

3. Create a new layer and name it mask. Put this layer 
directly above the layer containing the image. 

2. Use a drawing tool, such as the Oval tool or the 
Rectangle tool, to define the area of the mask layer that 
you want to be transparent (Figure 1).  

Make the transparent area of the mask a solid, noticeable 
color. This will help you see where the transparent area 
is.

4. Right-click the mask layer and select Mask from the 
pop-up menu. 

The two layers change to indicate that the bottom layer 
is masked. The name of the masked layer is indented 
under the name of the masking layer and its icon 
changes to a mask layer icon (Figure 2). 

 Note: To display the mask effect, lock both the mask 
layer and the layer containing the masking content. 
Unlock one or both layers to hide the effect. 

5. Select Control > Test Movie to see it play. 

Observe that only the masked area is visible. 

6. Select File > Close to close the preview window. 

Figure 1 Mask layer with mask area 

Figure 2 Mask applied 

Mask layer 

Mask area 

Lock icon Mask icon 

© 2007 Adobe Systems Incorporated How to create masks 1



Activity 5.4 guide Adobe Flash CS3  

Animating the mask 

You can animate the mask so that, for example, the mask pans along a picture. 

7. On the mask layer, add a keyframe at frame 20. 

8. On the masked layer below, also add a keyframe at 
frame 20. 

9. On the Mask layer, click the keyframe at frame 20 to 
select the mask object. 

10. Unlock the mask layer and move the mask object. 

11. On the Mask layer, right-click (Windows) or Control-
click (Mac OS) any frame between frames 1 and 20. 
Select Create Motion Tween from the context menu. 

A motion tween appears on the mask layer (Figure 3). 

12. Select Control > Test Movie to see it play. 

Observe that only the masked area moves across the 
content beneath it. 

13. Select File > Close to close the preview window. Figure 3 Motion tween on the mask layer 

Change the masked content 

You can change content on the layer below the mask while keeping the mask the same. 

14. On the object layer, select frame 10 and select Insert > 
Timeline > Blank Keyframe. 

Inserting a blank keyframe clears the contents of the 
frame. 

The contents of the object layer clear. 

15. Add new content to the object layer at frame 10. 

For example, you could drag a different picture to the 
Stage.

16. Select Control > Test Movie to see it play. 

Observe that the area under the mask changes halfway 
through the animation. 

17. Select File > Close to close the preview window. 

Reverting the masked content to its original state 

18. Select frame 10 (where you inserted the second 
keyframe), and select Modify > Timeline > 
Clear Keyframe. 

 This reverts the keyframe to a regular frame, and 
changes the layer back to its original state. 
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How to use a motion guide for animation 
You can use motion guides to create motion tweens that are more complex than those you can create with 
keyframes. Using a motion guide, you can move an object along any path you create with the Adobe Flash CS3 
drawing tools. You can create a motion guide for a shape, text, or a symbol. 

1. Select the layer that contains the object you wish to 
animate. 

2. Select Insert > Timeline > Motion Guide. 

Flash creates a special layer named Guide (Figure 1). 

3. Click the first frame of the Guide layer. 

4. On the Stage, use one of the Flash drawing tools, such 
as the Pencil or Pen, to draw a path that will guide the 
motion of the animation object. 

5. On both layers, insert keyframes at frame 20. 

6. On the object layer, right-click (Windows) or Control-
click (Mac OS) any frame between frames 1 and 20. 
Select Create Motion Tween from the context menu. 

7. Click the first frame of the object layer to select the 
object.

8. If it is not already there, drag the object by its center to 
the start of the guide.  

It should snap to the guide when you approach it. 

9. Click frame 20 of the object layer. 

10.  Drag the object by its center to the end of the guide. 

It should snap to the guide when you approach it 
(Figure 2).

11.  Turn Onion Skinning on to see how the object will move 
(Figure 3).

12. Select Control > Test Movie to see it play. 

Observe that the object moves along the guide. 

13. Select File > Close to close the preview window. 

Figure 1 Guide layer 

Figure 2 Snap to guide 

Figure 3 Object moving along guide 
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How to create and edit symbols 
A symbol is a reusable object stored in a library for an Adobe Flash CS3 document. It can be as simple as a static 
drawing or as complex as a movie clip that runs within another movie clip. Both you and Flash Player can reuse 
symbols stored in the library. Not only does this approach speed development, it also helps keep your document 
small, making it faster for site visitors to download. 

Each symbol has its own Timeline. You can add frames, keyframes, and layers to a symbol Timeline, just as you can 
to the main Timeline. 

An instance is a copy of a symbol located on the Stage or inside the Timeline of another symbol. An instance can 
differ from its symbol in color, size, and other characteristics set through the Property inspector. Editing the symbol 
updates all its instances, but applying effects or changing the properties of an instance of a symbol changes only that 
instance.

Creating a new symbol 

1. Select Insert > New Symbol. 

 The Create New Symbol dialog box opens (Figure 1). 

2. In the Create New Symbol dialog box, give the new 
symbol a name and select a symbol type. 

3. Click OK. 

 The new symbol has been created and opens in symbol-
editing mode. 

4. Add content to the symbol. 

5. To exit symbol-editing mode and return to the main 
Timeline, click Scene 1 on the edit bar (Figure 2).

 The new symbol is stored in the Document library and 
can be reused in this and other Flash documents. 

Figure 1 Create New Symbol dialog box 

Figure 2 Edit bar 

Converting an existing object to a symbol 

1. Select the object you want to convert to a symbol. 

 Note: To select both the stroke and the fill of a shape, 
you must double-click the fill unless the object is 
grouped. A single click on the fill selects only the fill, 
and a double-click on the stroke selects only the stroke. 

2. Select Modify > Convert To Symbol. 

The Convert To Symbol dialog box opens (Figure 3). 

3. In the Convert To Symbol dialog box, give the new 
symbol a name, and select a symbol type. 

 The object is now a symbol that is stored in the 
Document library and can be reused in this and other 
documents.  

4. Select Window > Library to open the Library panel and 
see your new symbol. 

Figure 3 Convert To Symbol dialog box 
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Editing a symbol 
You can edit an existing symbol either through the Library panel or in place on the Stage. You can also use the Edit 
In Place command to edit a symbol The Edit In Place command lets you edit a symbol while still viewing other 
objects on the Stage. Editing a symbol is different from changing the properties of a symbol instance. When you 
click a symbol on the Stage and change its properties, you are changing the symbol instance, not the symbol itself. 
In this case, only the instance is affected. When you edit the symbol itself, all instances of the symbol are affected. 

Editing a symbol through the library 

When you edit a symbol through the library, Flash updates all instances of the symbol on the Stage. If the symbol 
has no instances (that is, if you have not copied it from the Library panel to the Stage), nothing on the Stage changes 
when you edit the symbol. 

1. Select the symbol in the Library panel. 

2. Double-click the symbol, or open the Library panel 
menu and select Edit (Figure 4).

The symbol opens in symbol-editing mode. 

3. Make changes to the symbol. 

4. To exit symbol-editing mode and return to the main 
Timeline, click Scene 1 on the edit bar. 

Figure 4 Library panel menu 

Editing a symbol through the Stage 

1. Select the symbol on the Stage. 

2. Select Edit > Edit Symbols. 

The symbol opens in symbol-editing mode. All other 
objects on the Stage disappear (Figure 5).

3. Make changes to the symbol. 

4. To exit symbol-editing mode and return to the main 
Timeline, click Scene 1 on the edit bar. 

Figure 5 Symbol in symbol-editing mode 

Using the Edit In Place command 

1. Select the symbol on the Stage. 

2. Select Edit > Edit In Place. 

The symbol opens in symbol-editing mode, but all other 
objects on the Stage remain visible (Figure 6). 

3. Make changes to the symbol. 

4. To exit symbol-editing mode and return to the main 
Timeline, click Scene 1 on the edit bar. 

Figure 6 Symbol-editing by using the Edit In 
Place command 
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